Requirements:

Because I have a 32 bit cplex studio I received error for working with java 64 and it took a while for me to figure that I need a 32 bit Java.

1- JDK 32 bit.

2- Java Eclipse 32 bit. I had problem with 64 bit.

After installing JDK a folder contains jre. After extracting Java Eclipse (I am using NEON) you can copy jre folder to the neon folder and now you have portable Java eclipse.

 We assume that cplex is already installed.
 
Follow the instruction from :

http://www.ibm.com/support/knowledgecenter/SSSA5P_12.3.0/ilog.odms.cplex.help/Content/Optimization/Documentation/Optimization_Studio/_pubskel/ps_gscplex1296.html
{module javaCplexWrapper}
 

Instead of adding -Djava.library.path= ... to VM arguments I added the following address to my cplex

 Project Properties >

cplex/v12.6.3/opt/ibm/ILOG/CPLEX_Studio1263/cplex/bin/x86-64_linux